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Screen Layout 

When you begin to explore Excel 2007 you will notice a new look. There are four features that you 
should remember as you work within Excel 2007: the Microsoft Office Button, the Quick Access Toolbar, 
the Ribbon and the View Choices. 

 

 

 

 

 

 

 

Quick Access 
Toolbar 

View Options 

Ribbon Office Button 
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The Office Button 

The Microsoft Office button performs many of the functions that were located in the File menu of older 
versions of Word. 

 

Quick Access Toolbar 

The quick access toolbar is a customizable toolbar that contains commands that you may want to use. 
You can place the quick access toolbar above or below the ribbon. To change the location of the quick 
access toolbar, click on the arrow at the end of the toolbar and click on Show Below the Ribbon. 

 

You can also add items to the quick access toolbar. Right click on any item in the Office Button or the 
Ribbon and click on Add to Quick Access Toolbar and a shortcut will be added to the Quick Access 
Toolbar. 
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The Ribbon 

 

The Ribbon is the panel at the top portion of the window. It has seven tabs: Home, Insert, Page Layout, 
Formulas, Data, Review, and View that contain many new and existing features of Excel. Each tab is 
divided into groups. The groups are logical collections of features designed to perform functions that 
you will utilize in developing or editing your Excel spreadsheet. Commonly used features are displayed 
on the Ribbon, to view additional features within each group, click on the arrow at the bottom right of 
each group. 

 

Ribbon tabs in Excel:  

 

Dialog Box Launchers 

Some command sets on the Ribbon are also available in traditional style dialog boxes. The presence of a 
small arrow in the lower right corner of a command set indicates that you can click that "launcher" to 
display a dialog box containing those commands. For example, if you click the Dialog Box Launcher in the 
Font command set on the Home tab, the Font dialog box appears with the Font tab selected, as shown 
below.  
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 Tip:   You also will find a Dialog Box Launcher available at the bottom of any gallery that shows 
advanced options.  
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View Choices 

To view a spreadsheet in different ways, click the spreadsheet views shortcuts at the bottom of the 
screen or drag the slider bar + or ‐ . 

 

To Create a New Document 

 

 Click the Office Button             and choose 
New   

 

 

 

 

 

 

 

 

Opening an Existing Workbook 

 Click the Microsoft Office Button   and Click Open, or  

 If you have recently used the document you can click the Microsoft Office Button and click the 
name of the document in the Recent Documents section of the window  

You will notice that when you click on the 
Microsoft Office Button and Click New, you have 
many choices about the types of documents you 
can create. If you wish to start from a blank 
spreadsheet, click Blank.  If you wish to start from 
a template you can browse through your 
categories on the left, see the selections within a 
category in the center screen, and preview the 
selection on the right screen. 
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Saving a Workbook 

 Click the Microsoft Office Button   and Click Save or Save As (remember, if you’re sending 
the document to someone who does not have Office 2007, you will need to click the Office 
Button, click Save As, and Click Excel 97‐2003 Document) 

Close a Workbook 

 Click the Office Button  

 Click Close  

Managing larger data collections 

 

The Mini-toolbar 

When you select a cell, you can show or hide a handy, miniature, semitransparent toolbar called the 
Mini toolbar. The Mini toolbar helps you work with fonts, font styles, font sizing, alignment, text color, 
indent levels, and bullet features. 

Note: You cannot customize the Mini toolbar. 

The graphic that follows shows the Mini toolbar at the top of a shortcut menu. And, yes, if you would 
prefer not to have the Mini toolbar appear, you can turn it off. 
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Introducing galleries 

In Excel 2007, you can apply formats to your Excel worksheets, charts, and other objects directly by 
selecting the appearance you want from a gallery. Excel 2007 has three types of galleries: the drop‐
down gallery, the grid layout gallery, and the embedded gallery. The following graphics show all three 
types of galleries. 

Regardless of how Excel presents the gallery, you can format your object with one or two mouse clicks. 
You also have the ability to create custom gallery entries by clicking the New item at the bottom of some 
galleries and using the dialog box that appears to define your new gallery entry. 

 

Drop‐down gallery: 

 
Grid gallery: 

 
Embedded gallery 
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Themes 

In the past, it took time to format Microsoft Office documents to match because you had to choose 
color or style options for your tables, charts, shapes, and diagrams separately. In the 2007 Microsoft 
Office system, themes simplify the process of creating matching, professional‐looking documents not 
only within one program but across multiple programs. The same themes are now available in Microsoft 
Office Excel 2007, Microsoft Office PowerPoint 2007, Microsoft Office Word 2007, and Microsoft Office 
Outlook 2007, and you can easily apply a theme with one click. Use themes to give all of your 
organization's communications a branded look. 

 
The same theme used in Office PowerPoint 2007, Office Excel 2007, and Office Word 2007 

 

All of your content links to the theme. If you change the theme, a complete set of new colors, fonts, and 
effects is applied to your entire 2007 Office release document. Themes are an entirely new way to give 
all of your 2007 Office release documents a modern and professional look. If you created your 
document in an earlier version of Office, your text or graphics may not be themed and so won't change 
if you change the theme. 

To try different themes, rest your pointer over a thumbnail in the Themes gallery and notice how your 
document changes. 
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Four themes that are applied to the same SmartArt graphic. Clockwise from the upper left: Metro, the 
default Office theme, Apex, and Trek. 

 

Tip:   You can download additional themes from Microsoft Office Online. In the Themes gallery, click the 
More Themes on Microsoft Office Online link.  

Applying a new theme changes the major details of your document. WordArt colors and fonts, but not 
effects, are applied to titles. Tables, charts, SmartArt graphics, shapes, and other objects are updated to 
complement one another.  
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Excel cell styles 

A cell style is a defined set of formatting characteristics, such as fonts and font sizes, number formats, 
cell borders, and cell shading. To prevent others from changing specific cells, you can also use a cell style 
that locks cells. Office Excel 2007 has several built‐in cell styles that you can apply or modify. You can 
also modify or duplicate a cell style to create your own custom cell style. 

Cell styles are based on the document theme that is applied to an entire workbook. When you switch to 
another theme, the cell styles are updated to match the new theme. Built‐in cell styles are aware of 
theme fonts, but many are not theme color aware. None of the cell styles are related to theme effects. 

 

 

 

Formatting cells and worksheets 

Excel has always been a great program for analyzing numerical data, but even Office Excel 2003 came up 
a bit short in the presentation department. Office Excel 2007 offers vast improvements over the color 
management and formatting options found in previous versions of the program. You can have as many 
different colors in a workbook as you like, and you can assign a design theme to a workbook. Assigning a 
theme to a workbook offers you color choices that are part of a complementary whole, not just a dialog 
box with no guidance about which colors to choose. You can, still select any color you want when you 
format your worksheet, define custom cell styles, and create your own themes. The preinstalled themes 
are there as guides. 
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Use Formula AutoComplete 

To make it easier to create and edit formulas and minimize typing and syntax errors, use Formula 
AutoComplete. After you type an = (equal sign) and beginning letters or a display trigger, Microsoft 
Office Excel displays below the cell a dynamic drop‐down list of valid functions, names, and text strings 
that match the letters or trigger. You can then insert an item in the drop‐down list into the formula by 
using an insert trigger. 

 

 

 

 Type the = (equal sign) and beginning letters or a 

display trigger to start Formula AutoComplete. 

 As you type, a scrollable list of valid items is 
displayed with the closest match highlighted. 

 Icons represent the type of entry, such as a 
function or table reference. 

 Detailed ScreenTips help you make the best 
choice. 
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Formulas tab 

Find all the Formulas that you normally use as well as the new ones located on the Formulas tab in the 
Function Library group. 

 

 

Managing data tables more effectively 

You’ll often discover that it makes sense to arrange your Office Excel 2007 data as a table, in which each 
column contains a specific data element (such as an order number or the hours you worked on a given 
day), and each row contains data about a specific business object (such as the details of delivery number 
1403). In Office Excel 2007, tables enable you to enter and summarize your data efficiently. If you want 
to enter data in a new table row, all you have to do is type the data in the row below the table. After 
you press Tab or Enter after typing in the last cell’s values, Office Excel 2007 expands the table to 
include your new data. You can also have Office Excel 2007 display a Totals row, which summarizes your 
table’s data using a function you specify. 
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Excel table enhancements 

In Office Excel 2007, you can use the new user interface to quickly create, format, and expand an Excel 
table (known as an Excel list in Excel 2003) to organize the data on your worksheet so that it's much 
easier to work with. New or improved functionality for tables includes the following features. 

Table header rows   Table header rows can be turned on or off. When table headers are displayed, they 
stay visible with the data in the table columns by replacing the worksheet headers when you move 
around in a long table. 

Calculated columns   A calculated column uses a single formula that adjusts for each row. It 
automatically expands to include additional rows so that the formula is immediately extended to those 
rows. All that you have to do is enter a formula once—you don't need to use the Fill or Copy commands. 

Automatic AutoFiltering   AutoFilter is turned on by default in a table to enable powerful sorting and 
filtering of table data. 

Structured references   This type of reference allows you to use table column header names in formulas 
instead of cell references, such as A1 or R1C1. 

Total rows   In a total row, you can now use custom formulas and text entries. 

Table styles   You can apply a table style to quickly add designer‐quality, professional formatting to 
tables. If an alternate‐row style is enabled on a table, Excel will maintain the alternating style rule 
through actions that would have traditionally disrupted this layout, such as filtering, hiding rows, or 
manual rearranging of rows and columns. 

Summarizing data using new functions 

The Office Excel 2007 programming team encourages users to suggest new capabilities that might be 
included in the future versions of the program. One of the most common requests from corporations 
using Excel was to find the average value of cells where the value met certain criteria. For example, in a 
table summarizing daily sales by department, a formula could summarize sales in the Housewares 
department for days in which the sales total was more than $10,000. 

The Office Excel 2007 team responded to those requests by creating five new formulas that enable you 
to summarize worksheet data that meets a given condition. Here are quick descriptions of the new 
functions and any existing functions to which they’re related: 

• AVERAGEIF enables you to find the average value of cells in a range for cells that meet a single 
criterion.  

• AVERAGEIFS enables you to find the average value of cells in a range for cells that meet multiple 
criteria.  
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• SUMIFS, an extension of the SUMIF function, enables you to find the average value of cells in a 
range for cells that meet multiple criteria.  

• COUNTIFS, an extension of the COUNTIF function, enables you to count the number of cells in a 
range that meet multiple criteria.  

• IFERROR, an extension of the IF function, enables you to tell Excel 2007 what to do in case a 
cell’s formula generates an error (as well as what to do if the formula works the way it’s 
supposed to).  

Creating better conditional formats 

Businesses often use Excel to track corporate spending and revenue. The actual figures are very 
important, of course, but it's also useful for managers to be able to glance at their data and determine 
whether the data exceeds expectations, falls within an acceptable range, or requires attention because 
the value falls below expectations. In versions prior to Excel 2007, you could create up to three 
conditions and define a format for each one. For example, you could create the following rules: 

• If monthly sales are more than 10 percent ahead of sales during the same month in the previous 
year, display the value in green;  

• If monthly sales are greater than or equal to sales during the same month in the previous year, 
but are less than 10 percent greater, display the value in yellow;  

• If monthly sales are less than sales during the same month in the previous year, display the 
value in red.  

 
In Excel 2007 you can have as many rules as you like, apply several rules to a single data value, choose to 
stop evaluating rules after a particular rule has been applied, and change the order in which the rules 
are evaluated without having to delete and re‐create the rules you change. As shown in the figure, you 
can also apply several new types of conditional data formats: data bars, which create a horizontal bar 
across a cell indicating how large the value is; color gradients, which change a cell's fill color to indicate 
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how large the value is; and icon sets, which display one of the available icons depending on the 
guidelines you establish. 

Creating more attractive charts 

Office Excel 2007 enables you to manage large amounts of numerical data effectively, but humans 
generally have a hard time determining patterns from that data if all they have to look at are the raw 
numbers. That’s where charts come in. Charts summarize your data visually, which means that you and 
other decision‐makers can quickly detect trends, determine high and low data points, and forecast 
future prospects using mathematical tools. The Excel charting engine and color palette haven’t changed 
significantly since Excel 97, but Office Excel 2007 marks a tremendous step forward with more ways to 
create attractive and informative charts quickly.  

 

 
 

Select the type of chart you would like to use from the Insert tab, Charts group. 
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Controlling printouts more carefully 

One of the Office Excel 2007 product group’s goals for Office Excel 2007 was to enable you to create 
great‐looking documents. Of course, to create these documents, you must know what your documents 
will look like when you print them. The Microsoft Excel team introduced the Page Break Preview view in 
Excel 97; however it is somewhat limited from a printing control and layout perspective. In Office Excel 
2007 when you display a workbook in Page Layout view, you see exactly what your work will look like on 
the printed page. The Page Layout view also enables you to change your workbook’s margins, add and 
edit headers and footers, and edit your data. 

 

 
 

 

Create a SmartArt graphic 

A SmartArt graphic is a visual representation of your information that you can quickly and easily create, 
choosing from among many different layouts, to effectively communicate your message or ideas. 
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Before you create your SmartArt graphic, visualize what type and layout are best for displaying your 
data. What do you want to convey with your SmartArt graphic? Do you want a certain look? Since you 
can quickly and easily switch layouts, try different layouts (across types) until you find the one that best 
illustrates your message. Your graphic should be clear and easy to follow. Experiment with different 
types by using the table below as a starting point. The table is intended to help you get started and is 
not an exhaustive list. 

 

Purpose of SmartArt graphic Graphic type 

Show non‐sequential information List  

Show steps in a process or timeline Process  

Show a continual process Cycle  

Show a decision tree Hierarchy  

Create an organization chart Hierarchy 

Illustrate connections Relationship 

Show how parts relate to a whole Matrix 

Show proportional relationships with the largest component on the 
top or bottom  

Pyramid 

Also, consider the amount of text that you have, because the amount of text often determines the 
layout that you use and how many shapes you need in the layout. In general, SmartArt graphics are 
most effective when the number of shapes and the amount of text are limited to key points. Larger 
amounts of text can distract from the visual appeal of your SmartArt graphic and make it harder to 
convey your message visually. However, some layouts, such as Trapezoid List in the List type, work well 
with larger amounts of text. 
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Some layouts for SmartArt graphics contain a fixed number of shapes. For example, the Counterbalance 
Arrows layout in the Relationship type is designed to show two opposing ideas or concepts. Only two 
shapes can contain text, and the layout cannot be changed to display more ideas or concepts. 

 
If you need to convey more than two ideas, switch to another layout that has more than two shapes for 
text, such as the Basic Pyramid layout in the Pyramid type. Keep in mind that changing layouts or types 
can alter the meaning of your information. For example, a layout with arrows pointing to the right, such 
as Basic Process in the Process type, has a different meaning from a SmartArt graphic with arrows going 
in a circle, such as Continuous Cycle in the Cycle type. 

Remove duplicate values 

When you remove duplicate values, only the values in the range of cells or table are affected. Any other 
values outside the range of cells or table are not altered or moved. 

 Caution   Because you are permanently deleting data, it's a good idea to copy the original range of cells 
or table to another worksheet or workbook before removing duplicate values. 

1. Select the range of cells, or make sure that the active cell is in a table.  

2. On the Data tab, in the Data Tools group, click Remove Duplicates.  

 

3. Do one or more of the following:  

 Under Columns, select one or more columns.  

 To quickly select all columns, click Select All.  

 To quickly clear all columns, click Unselect All.  

If the range of cells or table contains many columns and you want to only select a few columns, you may 
find it easier to click Unselect All, and then under Columns, select those columns. 

4. Click OK.  
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A message is displayed indicating how many duplicate values were removed and how many unique 
values remain, or if no duplicate values were removed. 

5. Click OK. 
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Conditionally format unique or duplicate values 

 Note   You cannot conditionally format fields in the Values area of a PivotTable report by unique or 
duplicate values. 

Quick formatting 

1. Select one or more cells in a range, table, or PivotTable report.  

2. On the Home tab, in the Style group, click the arrow next to Conditional Formatting, and then 
click Highlight Cells Rules.  

 

3. Select Duplicate Values.  

4. Enter the values that you want to use, and then select a format. 

Define a name by using the New Name dialog box 

The Name Manager dialog box makes it much easier to see all your named ranges and to specify any 
specific parameters associated with the name. 

 

1. On the Formulas tab, in the Defined Names group, click Define Name.  
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2. In the New Name dialog box, in the Name box, type the name that you want to use for your 
reference.  

 Note   Names can be up to 255 characters in length. 

3. To specify the scope of the name, in the Scope drop‐down list box, select Workbook or the 
name of a worksheet in the workbook.  

4. Optionally, in the Comment box, enter a descriptive comment up to 255 characters.  

 Note   If you save the workbook to Microsoft Office SharePoint Server 2007  Excel Services, and you 
specify one or more parameters, the comment is used as a ScreenTip in the Parameters Task Pane. 

5. In the Refers to box, do one of the following:  

 To enter a cell reference, type the cell reference.  

Tip   The current selection is entered by default. To enter other cell references as an argument, click 

Collapse Dialog (which temporarily shrinks the dialog box), select the cells on the worksheet, and 

then click Expand Dialog . 

 To enter a constant, type = (equal sign) and then type the constant value.  

 To enter a formula, type = and then type the formula.  

6. To finish and return to the worksheet, click OK.  

 Tip   To make the New Name dialog box wider or longer, click and drag the grip handle at the bottom. 
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New file formats 

XML‐based file format   In 2007 Microsoft Office system, Microsoft is introducing new file formats for 
Word, Excel, and PowerPoint, known as the Office Open XML formats. These new file formats facilitate 
integration with external data sources, and also offer reduced file sizes and improved data recovery. In 
Office Excel 2007, the default format for an Excel workbook is the Office Excel 2007 XML‐based file 
format (.xlsx). Other available XML‐based formats are the Office Excel 2007 XML‐based and macro‐
enabled file format (.xlsm), the Office Excel 2007 file format for an Excel template (.xltx), and the Office 
Excel 2007 macro‐enabled file format for an Excel template (.xltm). 

Office Excel 2007 binary file format   In addition to the new XML‐based file formats, Office Excel 2007 
also introduces a binary version of the segmented compressed file format for large or complex 
workbooks. This file format, the Office Excel 2007 Binary (or BIFF12) file format (.xls), can be used for 
optimal performance and backward compatibility. 

Compatibility with earlier versions of Excel   You can check an Office Excel 2007 workbook to see if it 
contains features or formatting that are not compatible with an earlier version of Excel so that you can 
make the necessary changes for better backward compatibility. In earlier versions of Excel, you can 
install updates and converters that help you open an Office Excel 2007 workbook so that you can edit it, 
save it, and open it again in Office Excel 2007 without losing any Office Excel 2007‐specific functionality 
or features. 
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Find your favorite Excel 2003 commands in the new Excel 2007 interface 

File Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

File > New Office button > New Ctrl‐N 

File > Open Office button > Open Ctrl‐O 

File > Close Office button > Close Ctrl‐W 

File > Save Office button > Save 
or 
Quick Access tool bar > Save icon 

Ctrl‐S 

File > Save As Office button > Save As F12 

File > Save As Web 
Page 

Office button > Save As (in Save As dialog, choose 
Web Page from Save As Type drop‐down) 

In Excel 2003: Alt‐F, G 
In Excel 2007: F12 (in 
Save As dialog, choose 
Web Page from Save As 
Type drop‐down) 

File > Save 
Workspace 

View > Window > Save Workspace In Excel 2003: Alt‐F, W 
In Excel 2007: Alt‐W, K 

File > File Search Windows Start button > Search In Excel 2003: Alt‐F, H 
In Excel 2007: Window 
key, C  

File > Permission Office button > Prepare > Restrict Permission In Excel 2003: Alt‐F, M 
In Excel 2007: Alt‐F, E, R 

File > Web Page 
Preview 

Add to Quick Access tool bar: Office button > Excel 
Options > Customize > All Commands > Web Page 
Preview 

In Excel 2003: Alt‐F, B 
In Excel 2007: Alt‐
[number of position in 
Quick Access tool bar] 

File > Page Setup Page Layout > Page Setup (click dialog box launcher 
for more options) 
or 
Office button > Print > Print Preview > Page Setup 
icon 

In Excel 2003: Alt‐F, U 
In Excel 2007: Alt‐P, SP 
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File > Print Area Page Layout > Page Setup > Print Area In Excel 2003: Alt‐F, T 
In Excel 2007: Alt‐P, R 

File > Print 
Preview 

Office button > Print > Print Preview In Excel 2003: Alt‐F, V 
In Excel 2007: Alt‐F, W, V 

File > Print Office button > Print Ctrl‐P 

File > Send To Office button > Send 
(for more Send options, see Office button > Excel 
Options > Customize > All Commands) 

Alt‐F, D 

File > Most 
Recently Used 
Documents 

Office button > Recent Documents Alt‐F 

 

Edit Menu 

Excel 2003 Location Excel 2007 Location Keyboard Shortcut 

Edit > Undo Quick Access tool bar > Undo icon Ctrl‐Z 

Edit > Redo Quick Access tool bar > Redo icon Ctrl‐Y 

Edit > Cut Home > Clipboard > Cut Ctrl‐X 

Edit > Copy Home > Clipboard > Copy Ctrl‐C 

Edit > Office 
Clipboard 

Home > Clipboard dialog box launcher In Excel 2003: Alt‐E, B 
In Excel 2007: Alt‐H, FO 

Edit > Paste Home > Clipboard > Paste Ctrl‐V 

Edit > Paste Special Home > Clipboard > Paste > Paste Special In Excel 2003: Alt‐E, S 
In Excel 2007: Alt‐E, S or 
Alt‐Ctrl‐V 

Edit > Paste as 
Hyperlink 

Home > Clipboard > Paste > Paste as Hyperlink Alt‐E, H 

Edit > Fill Home > Editing > Fill In Excel 2003: Alt‐E, I 
In Excel 2007: Alt‐H, FI 

Edit > Clear Home > Editing > Clear In Excel 2003: Alt‐E, A 
In Excel 2007: Alt‐H, E 

Edit > Delete Home > Cells > Delete In Excel 2003: Alt‐E, D 
In Excel 2007: Alt‐H, D 
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Edit > Delete Sheet Home > Cells > Delete > Delete Sheet In Excel 2003: Alt‐E, L 
In Excel 2007: Alt‐H, D, 
S 

Edit > Move or 
Copy Sheet 

Home > Cells > Format > Move or Copy Sheet In Excel 2003: Alt‐E, M 
In Excel 2007: Alt‐H, O, 
M 

Edit > Find Home > Editing > Find & Select > Find Ctrl‐F 

Edit > Replace Home > Editing > Find & Select > Replace Ctrl‐H 

Edit > Go To Home > Editing > Find > Find & Select > Go To Ctrl‐G 

 

View Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

View > Normal View > Workbook Views > Normal In Excel 2003: Alt‐V, N 
In Excel 2007: Alt‐W, L 

View > Page 
Break Preview 

View > Workbook Views > Page Break Preview In Excel 2003: Alt‐V, P 
In Excel 2007: Alt‐W, I 

View > Task Pane The overall task pane is gone in Excel 2007, but some 
dialog box launchers display task panes. 

In Excel 2003: Ctrl‐F1 
In Excel 2007: not 
available 

View > Tool bars Excel 2007 no longer has tool bars. In Excel 2003: Alt‐V, T 
In Excel 2007: not 
available 

View > Formula 
Bar 

View > Show/Hide > Formula Bar Alt‐V, F 

View > Status Bar The Status Bar is always visible. In Excel 2003: Alt‐V, S 
In Excel 2007: not 
available 

View > Header 
and Footer 

Insert > Text > Header & Footer Alt‐V, H 

View > 
Comments 

Review > Comments > Show All Comments Alt‐V, C 

View > Custom View > Workbook Views > Custom Views In Excel 2003: Alt‐V, V 
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Views In Excel 2007: Alt‐W, C 

View > Full 
Screen 

View > Workbook Views > Full Screen Alt‐V, U 

View > Zoom View > Zoom > Zoom Alt‐V, Z 

 

Insert Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

Insert > Cells Home > Cells > Insert > Insert Cells Alt‐I, E 

Insert > Rows Home > Cells > Insert > Insert Sheet Rows Alt‐I, R 

Insert > Columns Home > Cells > Insert > Insert Sheet Columns Alt‐I, C 

Insert > 
Worksheet 

Home > Cells > Insert > Insert Sheet Alt‐I, W 

Insert > Chart Insert > Charts Alt‐I, H 

Insert > Symbol Insert > Text > Symbol In Excel 2003: Alt‐I, S 
In Excel 2007: Alt‐I, S or 
Alt‐N, U 

Insert > Page 
Break 

Page Layout > Page Setup > Breaks > Insert Page 
Break 

Alt‐I, B 

Insert > Function Formulas > Function Library > Insert Function In Excel 2003: Alt‐I, F 
In Excel 2007: Alt‐I, F or 
Alt‐M, F 

Insert > Name Formulas > Defined Names In Excel 2003: Alt‐I, N 
In Excel 2007: Alt‐M, M 

Insert > 
Comment 

Review > Comments > New Comment In Excel 2003: Alt‐I, M 
In Excel 2007: Alt‐I, M or 
Alt‐R, C 

Insert > Picture Insert > Illustrations In Excel 2003: Alt‐I, P 
In Excel 2007: Alt‐N, 
[letter depends on type of 
art inserted] 

Insert > Diagram Insert > Illustrations > SmartArt In Excel 2003: Alt‐I, G 
In Excel 2007: Alt‐N, M 
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Insert > Object Insert > Text > Object Alt‐I, O 

Insert > 
Hyperlink 

Insert > Links > Hyperlink Ctrl‐K 

 

Format Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

Format > Cells Home > Cells > Format > Format Cells Alt‐O, E 

Format > Row Home > Cells > Format In Excel 2003: Alt‐O, R 
In Excel 2007: Alt‐H, O 

Format > 
Column 

Home > Cells > Format In Excel 2003: Alt‐O, C 
In Excel 2007: Alt‐H, O 

Format > Sheet Home > Cells > Format In Excel 2003: Alt‐O, H 
In Excel 2007: Alt‐H, O 

Format > 
AutoFormat 

Home > Styles > Format as Table In Excel 2003: Alt‐O, A 
In Excel 2007: Alt‐O, A or 
Alt‐H, T 

Format > 
Conditional 
Formatting 

Home > Styles > Conditional Formatting In Excel 2003: Alt‐O, D 
In Excel 2007: Alt‐O, D or 
Alt‐H, L 

Format > Style Home > Styles > Cell Styles In Excel 2003: Alt‐O, S 
In Excel 2007: Alt‐O, S or 
Alt‐H, J 
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Tools Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

Tools > Spelling Review > Proofing > Spelling F7 

Tools > 
Research 

Review > Proofing > Research Alt‐Click 

Tools > Error 
Checking 

Formulas > Formula Auditing > Error Checking Alt‐T, K 

Tools > Speech Not in Excel 2007 In Excel 2003: Alt‐T, H 
In Excel 2007: not available 

Tools > Shared 
Workspace 

Office button > Publish > Create Document 
Workspace 

Alt‐T, D 

Tools > Share 
Workbook 

Review > Changes > Share Workbook In Excel 2003: Alt‐T, B 
In Excel 2007: Alt‐T, B or 
Alt‐R, W 

Tools > Track 
Changes 

Review > Changes > Track Changes In Excel 2003: Alt‐T, T 
In Excel 2007: Alt‐R, G 

Tools > 
Compare and 
Merge 
Workbooks 

Add to Quick Access tool bar: Office button > Excel 
Options > Customize > All Commands > Compare and 
Merge Workbooks 

Alt‐T, W 

Tools > 
Protection 

Review > Changes In Excel 2003: Alt‐T, P 
In Excel 2007: Alt‐R, [letter 
depends on type of 
protection] 

Tools > Online 
Collaboration 

Not in Excel 2007 In Excel 2003: Alt‐T, N 
In Excel 2007: not available 

Tools > Goal 
Seek 

Data > Data Tools > What‐If Analysis > Goal Seek Alt‐T, G 

Tools > 
Scenarios 

Data > Data Tools > What‐If Analysis > Scenario 
Manager 

Alt‐T, E 

Tools > 
Formula 
Auditing 

Formulas > Formula Auditing In Excel 2003: Alt‐T, U 
In Excel 2007: Alt‐M, [letter 
depends on type of 



  Excel 2007 Overview 

Copyright © 2008 Morning Star Computer Training and Consulting Page 35 

formula auditing] 

Tools > Macro View > Macros > Macros 
or 
Developer > Code > Macros 

In Excel 2003: Alt‐T, M 
In Excel 2007: Alt‐W, M 

Tools > Add‐Ins Office button > Excel Options > Add‐Ins Alt‐T, I 

Tools > 
AutoCorrect 
Options 

Office button > Excel Options > Proofing > 
AutoCorrect Options 

Alt‐T, A 

Tools > 
Customize 

Office button > Excel Options > Customize In Excel 2003: Alt‐T, C 
In Excel 2007: Alt‐F, I, C 

Tools > Options Office button > Excel Options In Excel 2003: Alt‐T, O 
In Excel 2007: Alt‐T, O or 
Alt‐F, I 

 

Data Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

Data > Sort Data > Sort & Filter > Sort 
or 
Home > Editing > Sort & Filter > Sort 

In Excel 2003: Alt‐D, S 
In Excel 2007: Alt‐A, S 

Data > Filter Data > Sort & Filter > Filter 
or 
Home > Editing > Sort & Filter > Filter 

In Excel 2003: Alt‐D, F 
In Excel 2007: Alt‐A, T 

Data > Form Add to Quick Access tool bar: Office button > Excel 
Options > Customize > All Commands > Form 

In Excel 2003: Alt‐D, O 
In Excel 2007: Alt‐[number 
of position in Quick Access 
tool bar] 

Data > 
Subtotals 

Data > Outline > Subtotal In Excel 2003: Alt‐D, B 
In Excel 2007: Alt‐D, B or Alt‐
A, B 

Data > 
Validation 

Data > Data Tools > Data Validation In Excel 2003: Alt‐D, L 
In Excel 2007: Alt‐D, L or Alt‐
A, V 

Data > Table Data > Data Tools > What‐If Analysis > Data Table Alt‐D, T 

Data > Text to Data > Data Tools > Convert Text to Table In Excel 2003: Alt‐D, E 
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Columns In Excel 2007: Alt‐D, E or Alt‐
A, E 

Data > 
Consolidate 

Data > Data Tools > Consolidate In Excel 2003: Alt‐D, N 
In Excel 2007: Alt‐D, N or 
Alt‐A, N 

Data > Group 
and Outline 

Data > Outline In Excel 2003: Alt‐D, G 
In Excel 2007: Alt‐A, [letter 
depends on group/outline 
selection] 

Data > 
PivotTable 
and 
PivotChart 
Report 

Insert > Tables > PivotTable > PivotTable/PivotChart Alt‐D, P 

Data > Import 
External Data 

Data > Get External Data In Excel 2003: Alt‐D, D 
In Excel 2007: Alt‐A, [letter 
depends on data source] 

Data > List Data > Get External Data Ctrl‐L 

Data > XML Developer > XML In Excel 2003: Alt‐D, X 
In Excel 2007: Alt‐L, X (when 
Developer tab is showing) 

Data > 
Refresh Data 

Data > Connections > Refresh All > Refresh All In Excel 2003: Alt‐D, R 
In Excel 2007: Alt‐A, R, A 
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Window Menu 

Excel 2003 
Location 

Excel 2007 Location Keyboard Shortcut 

Window > New 
Window 

View > Window > New Window Alt‐W, N 

Window > 
Arrange 

View > Window > Arrange All Alt‐W, A 

Window > 
Compare Side 
by Side with 

View > Window > View Side by Side Alt‐W, B 

Window > Hide View > Window > Hide Alt‐W, H 

Window > 
Unhide 

View > Window > Unhide Alt‐W, U 

Window > 
Split/Remove 
Split 

View > Window > Split/Remove Split Alt‐W, S (toggle) 

Window > 
Freeze 
Panes/Unfreeze 
Panes 

View > Window > Freeze Panes > Freeze 
Panes/Unfreeze Panes 

In Excel 2003: Alt‐W, F 
(toggle) 
In Excel 2007: Alt‐W, F, F 
(toggle) 

Window > 
Currently Open 
Workbooks 

View > Window > Switch Windows  In Excel 2003: Alt‐W 
In Excel 2007: Alt‐W, W 

 


